Напишите программу в ТУРБО ПАСКАЛЕВведите с клавиатуры переменные c и d. Если 0<c<d, то...

0 голосов
37 просмотров
Напишите программу в ТУРБО ПАСКАЛЕ
Введите с клавиатуры переменные c и d. Если 0

Информатика (1.5k баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Uses Graph; { Подключаем модуль }
var
  c,d,Gd,Gm:integer;
  k:real;
begin
  Writeln('10<=c<=460; 10<=d<=230');<br>  Write('Задайте c в пределах от 10 до 460: ');Read(c);
  if (c<10) or (c>460) then Writeln('Неверное значение!')
  else begin
    Write('Задайте d в пределах от 10 до 230: '); Readln(d);
    if (d<10) or (d>230) then Writeln('Неверное значение!')
    else begin
      Gd := Detect;
      InitGraph(Gd, Gm, 'Y:\tp7\bgi'); { Инициализируем графический режим }
      SetColor(4);
      k:=GetMaxX/GetMaxY; { Коэффициент искажений по осям }
      if c      else Line(Trunc(c/k),c,Trunc(d/k),d);
      Readln;
      CloseGraph
    end
  end
end.

(142k баллов)
0

'Y:\tp7\bgi' - это путь к папке \BGI Турбо Паскаль

0

А зачем нам указывать путь к папке Паскаля?

0

Так построена графическая подсистема у Турбопаскаль. Но если Вы будете запускать Турбопаскаль из его директории, то вместо пути можно указать строку из одного или более пробелов. Потому что этот путь используется тогда, когда папка \BGI не видна из директории запуска.

0

Видите первый оператор uses Graph? Он задает Турбопаскалю приказ найти файлы графики *.bgi, а по умолчанию они лежат в поддиректории \BGI