Напишите программу, упростив следующий фрагмент программы: if a>b then c:=1; if a>b then...

0 голосов
132 просмотров

Напишите программу, упростив следующий фрагмент программы:
if a>b then c:=1;
if a>b then d:=2;
if a<=b then c:=3;<br> if a<=b then d:=4.<br> Можно пожалуйста полностью прогу:с


Информатика (153 баллов) | 132 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a, b, c, d: integer;
begin
  read(a, b);
  if a > b then begin
    c := 1;
    d := 2;
  end else begin
    c := 3;
    d := 4;
  end;
  writeln('c = ', c, ' d = ', d);
end.

(13.3k баллов)
0 голосов

 program primer;
     var a,b,c,d:integer;
begin 
writeln ('введите значение для переменной a'); 
  readln(a); 
  writeln ('введите значение для переменной b'); 
    readln(b);   
          if  a>b then  
      begin c:=1; d:=2;         end
          else          begin c:=3; d:=4;      end;   
     writeln('c=',c,'  ','d=',d);  
 readln; 
end.

(2.4k баллов)