Напишите программу, которая вводит номер месяца и выводит название времени года **...

0 голосов
78 просмотров

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке. При вводе неверного номера месяца должно быть выведено слово 'NO'.


Информатика (53 баллов) | 78 просмотров
0

Нужно, чтобы программа выводила название месяца или время года?

Дан 1 ответ
0 голосов

// здесь кусок кода, в котором считываем введённый месяц в переменную
//month
char getTime(int month)
switch (month){
case '1' : return 'winter'; break;
case '2' : return 'winter'; break;
case '12' : return 'winter'; break;
case '3' : return 'spring'; break;
case '4' : return 'spring'; break;
case '5' : return 'spring'; break;
case '6' : return 'summer'; break;
case '7' : return 'summer'; break;
case '8' : return 'summer'; break;
case '9' : return 'autumn'; break;
case '10' : return 'autumn'; break;
case '11' : return 'autumn'; break;
default : 'NO'; break;
}
printf(getTime(month));

(818 баллов)