Помогите составить программу ** языке программирования Паскаль, которая бы содержала бы...

0 голосов
43 просмотров

Помогите составить программу на языке программирования Паскаль, которая бы содержала бы как минимум ТРИ ВЕТВЛЕНИЯ (if ... then ... else ...) и ОДИН ЦИКЛ (for i := 1 to ... do ...).


Информатика (36 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

program yourname;
uses crt;
var com:string; i:integer;
begin
writeln('Задайте значените программы.');
writeln('Для того чтобы программа посчитала от 1 до 5 пропишите команду  "go1".');
writeln('Для того чтобы программа посчитала от 5 до 1 пропишите команду  "go2".');
writeln('Для того чтобы сказать спасибо программе - пропишите команду "go3".');
readln(com);
If (com = 'go1') then begin
writeln(Программа считает от 1 до 5');
for i:=1 to 5 do writeln(i) end
else if (com = 'go2') then begin
writeln('Программа считает от 5 до 1');
for i:=5 downto 1 do writeln(i) end
else if (com = 'go3') then begin
writeln('Программа: Всегда рада вам помочь.'); end
else begin writeln('Данной команды не существует либо вы ввели команду вместе с ковычками.');
writeln('Пожалуйста! Перезапустите программу.') end

 

end.

(138 баллов)