Напишите программу, которая вводит два числа A и N вычисляет A^N. Програмный код. НЕ...

0 голосов
61 просмотров

Напишите программу, которая вводит два числа A и N вычисляет A^N.
Програмный код. НЕ через "power". Заранее спасибо


Информатика (472 баллов) | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Function Pow(a : Integer; b : Integer) : Integer;
Begin
  If b=0 then Pow:=1 else Pow:=a*Pow(a,b-1);
End;

Var A,N : Integer;
Begin
  Readln(A,N);
  Writeln(Pow(A,N));
end.

(5.1k баллов)
0

Не Вам решать какая у меня голова. Если так, то сможете вообще расписать подробно как получить любое число в любой степени

0

Не вводя функции подобные этой, а получить расписав через "while", например,"for","repeat"

0

Так что же Вы сразу не обозначили эти условия задачи? Вы думаете тут все телепаты и понимают то, что Вы недоговариваете? Что спросили - на то и получили ответ.

0

придёт модератор и нас рассудит

0

Претензии имеете ко мне?

0

Я? Никаких. Свое решение я привёл в рамках Ваших первоначально заданных условиях - и мое решение, по моему мнению, полностью отвечает условиям.

0

"Не вводя функции подобные этой, а получить расписав через "while", например,или "for" " Если распишите, чтобы понятно все было, то высказываю свою благодарность Вам и забираю свои упреки и недовольства обратно.

0

Var R,A,N : Integer;
Begin
Readln(A,N);
R:=1;
While N>0 do
Begin
R:=R*A;
Dec(N);
end;
Writeln(R);
end.

0

Спасибо^^.