Напишите программу которая выводит ** экран все подмножества множества:{'A','B','C','D'}.

0 голосов
51 просмотров

Напишите программу которая выводит на экран все подмножества множества:{'A','B','C','D'}.


Информатика (29 баллов) | 51 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const
  a:array[1..2] of string=('','A');
  b:array[1..2] of string=('','B');
  c:array[1..2] of string=('','C');
  d:array[1..2] of string=('','D');
var
  i,j,k,l:byte;
begin
  for i:=1 to 2 do
    for j:=1 to 2 do
      for k:=1 to 2 do
        for l:=1 to 2 do
          Write(d[i],c[j],b[k],a[l],' ')
end.

Тестовое решение:
 A B BA C CA CB CBA D DA DB DBA DC DCA DCB DCBA


(142k баллов)
0

Предполагается, что множество одновременно является собственным подмножеством. Если это не так, надо добавить условие, исключающее вывод при условии i+j+k+l=8

0

спс большое!

0

Для спс кнопочка синяя)))

0 голосов

Решение без многоуровневой вложенности (python 3.3):

def subsets(seq):
    if seq == []:
        yield []
        return
    for sub in subsets(seq[1:]):
        yield sub
    for sub in subsets(seq[1:]):
        yield [seq[0]] + sub

for x in subsets(['a', 'b', 'c', 'd']):
    print(x)

(942 баллов)