Составьте программу , выходящую ** экран все делители числа х .Число х введите с...

0 голосов
26 просмотров

Составьте программу , выходящую на экран все делители числа х .Число х введите с клавиатуры .
Пример ввода :
12
Пример вывода :
1 2 3 4 6 12


Информатика (30 баллов) | 26 просмотров
0

Да , в PascalABC

Дан 1 ответ
0 голосов
Правильный ответ

Var x,i :integer;
begin
writeln('x=');
readln(x);
for i:=1 to x do
 if x mod i =0 then write(i,' ');
writeln;
end.

(194k баллов)