Написать программу, которая вводит с клавиатуры не пустой массив целых чисел, печатает...

0 голосов
45 просмотров

Написать программу, которая вводит с клавиатуры не пустой массив целых чисел, печатает его, затем находит максимальный и минимальный элемент массива, выводит их на экран.


Информатика (15 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var  a: array [1..100] of integer;
i,n,min,max:integer;
Begin
    read(n);
    for i := 1 to n do
        read(a[i]);

    min:=a[1];
    max:=a[1];
    for i:= 1 to n do begin
        write(a[i],' ');
        if max        if min>a[i] then min:=a[i];
    end;
    writeln(min,max);
End.

(53.1k баллов)