Написать программу подсчета суммы вводимых элементов до первого отрицательно числа в...

0 голосов
75 просмотров

Написать программу подсчета суммы вводимых элементов до первого отрицательно числа в Pascal


Информатика (19 баллов) | 75 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal
var n, sum: integer;
begin
  sum := 0;
  while (n >= 0) do
  begin
    sum := sum + n;
    read(n);
  end;
  writeln(sum);
end.

(13.3k баллов)
0

Это с предусловием можно с послусловием

0

var n, sum: integer;
begin
sum := 0;
repeat
sum := sum + n;
read(n);
until n < 0;
writeln(sum);
end.

0

В следующий раз пишите в условии

0

Большое спасибо,спасли

0

Пожалуйста