Написать программу Заполнить массив из 15 элементов случайными числами (-50;50)Посчитать...

0 голосов
127 просмотров

Написать программу Заполнить массив из 15 элементов случайными числами (-50;50)Посчитать сумму всех элементов массива Посчитать количество отрицательных
элементов.


Информатика (14 баллов) | 127 просмотров
Дан 1 ответ
0 голосов

Если нужно на Паскале:

program test;
var mas : array[1..15] of integer;
sum : integer;
otr : integer;
i: integer;

begin
sum := 0;
otr := 0;
randomize;
for i:=1 to 15 do
begin
    mas[i] = -50 + random(100);
    sum := sum + mas[i];
    if mas[i] < 0
        then otr := otr + 1;
end;
writeln ('Сумма: ' + sum);
writeln ('Количество отрицательных элементов: ' + otr);
end.

(826 баллов)