Дана строка написать программу заменяющую в строке все буквы а ** букву о

0 голосов
117 просмотров

Дана строка написать программу заменяющую в строке все буквы а на букву о


Информатика (34 баллов) | 117 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Поскольку по условию задачи непонятно, на каком языке написана строка, то я написал программу, заменяющую АНГЛИЙСКУЮ "а" на АНГЛИЙСКУЮ "о". Если на другом языке - то программу можно переделать...

uses Crt;
var i : integer; 
   S, Snew : string;
begin 
ClrScr; 
 Write ('S = '); ReadLn(S); 
 Snew := ''; 
for i:=1 to length(S) do
    if S[i]='a' then Snew:=Snew+'o' 
                 else Snew:= Snew+S[i]; 
 WriteLn (S); 
 WriteLn (Snew); 
ReadLn;
end.

0

спасибо

0

спасибо