Как написать программу "Бегущая строка" ** языке Паскаль?

0 голосов
36 просмотров

Как написать программу "Бегущая строка" на языке Паскаль?


Информатика (46 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Uses Crt;
Procedure Beg(x,y,Len : Byte; S : String);
Var i : Byte;
Begin
  For i:=1 to Len do S:=' '+S+' ';
  Repeat
    GoToXY(x,y);
    Writeln(Copy(S,1,Len));
    Delete(S,1,1);
    Delay(100);
  Until Length(S)end;

Begin
  Beg(10,10,20,'Внимание! Совершает посадку рейс №123 маршрут Москва-Владивосток! Просьба встречающих пройти к выходу терминала №3.');
end.

(5.1k баллов)
0

Огромное спасибо!