Написать программу ** языке Паскаль Дано: а,b,с Найти:S S=SQRT(p(p-a)(p-b)(p-c)) где...

0 голосов
32 просмотров

Написать программу на языке Паскаль
Дано: а,b,с
Найти:S
S=SQRT(p(p-a)(p-b)(p-c))
где р=(а+b+c)/2


Информатика (626 баллов) | 32 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c,s:real;

procedure Pl(var a,b,c,s:real);
var p:real;
begin;
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln(s);
end;

begin;
readln(a);
readln(b);
readln(c);
if (a>=(b+c)) or (b>=(a+c)) or (c>=(a+b)) then
begin;
writeln('error');
exit;
end;
Pl(a,b,c,s);
end.

(38.6k баллов)
0 голосов

Var a,b,c,s:integer;
function f(a1,b1,c1:real):real;
var p:real;
begin
p:=(a+b+c)/2;
f:=sqrt(p*(p-a)*(p-b)*(b-c)); end;
BEGIN
readln(a,b,c);
writeln('S=',f(a,b,c):4:2);
end.