Помогите пожалуйста!!Умоляю! Нужно написать программу ** языке паскаль Дан массив из 10...

0 голосов
71 просмотров

Помогите пожалуйста!!Умоляю! Нужно написать программу на языке паскаль

Дан массив из 10 целых чисел. Определить, что больше: среднее арифметическое максимального и минимального элементов, или среднее арифметическое всех элементов массива.


Информатика (301 баллов) | 71 просмотров
0

Вон товарищ уже пишет ответ

0

Не, нафик вспоминать Делфи :Р

0

Ребятушки, выручайте) очень нужна помощь

0

Че это где тоДелфи учат?)))

0

Вроде устаревший он

0

устаревший, но программы заставляют в нем писать(

0

Это да, но если учить школьников С++, то они будут страдать. Плюс Делфи многое прощает.

0

нас не в школе а в универе заставлzют на нем писать :D

0

Дельфи - это платный продукт. Pabc.NET наше все!

0

D:

Дан 1 ответ
0 голосов

Var m : array[1..10] of Integer;
max,min,sum,i : Integer;
Begin
  min:=1; max:=1; sum:=0;
  For i:=1 to 10 do
  Begin
   m[i]:=Random(100);
   sum:=sum+m[i];
   If m[i]   If m[i]>m[max] then max:=i;
   Writeln(m[i]);
  end;
  Writeln('Ср.арифм. макс.и мин. элементов: ', (m[max]+m[min])/2);
  Writeln('Ср.арифм. всех элементов: ', sum/10);
end.

(5.1k баллов)
0

Спасибо большое) Вы меня спасли)