Плиз решите срочно !!!!!! Хотя бы пару из них. 1. Дано целое число N. Написать программу,...

0 голосов
38 просмотров
Плиз решите срочно !!!!!! Хотя бы пару из них.

1. Дано целое число N. Написать программу, заменяющую его нулем, если число меньше нуля, и увеличивающую его на 4, если число неотрицательное.
2. Даны целые числа A и B. Написать программу, которая выводит число 1, если числа равны, и число 0 в противном случае.
3. Даны целые числа A, В и С. Написать программу, подсчитывающую количество неотрицательных чисел среди данных.
4. Даны целые числа A, В и С. Написать программу, подсчитывающую сумму положительных чисел среди данных.
5. Даны числа A, В и С. Написать программу, выводящую их в убывающем порядке.
6. Даны целое трехзначное число N и целое число k. Написать программу, подсчитывающую сумму тех цифр числа N, которые больше k.
7. Дано натуральное число N. Написать программу, подсчитывающую сумму 1+2+3+…+N.
8. Даны натуральные числа А и В (В 9. Дано натуральное число N. Написать программу, выводящую на экран последовательность натуральных чисел от N до 1.
10. Дано натуральное число N. Написать программу для вычисления суммы .
11. Дано натуральное число N. Написать программу для вычисления суммы .
12. Дано натуральное число N (N<10). Написать программу, для вычисления суммы вида 0,1+0,2+0,3+… (N слагаемых).<br> 13. Дано натуральное число N. Написать программу, выводящую на экран последовательность квадратов всех чисел от 1 до N.
14. Дано натуральное число N. Написать программу, выводящую последовательность первых N нечетных чисел.
15. Дано N натуральных чисел. Написать программу, вычисляющую их среднее арифметическое. Число N вводится перед всеми остальными.
16. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, которая подсчитывает количество чисел в последовательности.
17. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, которая подсчитывает количество четных чисел в последовательности (число 0 для вычисления результата считать не надо).
18. Дана последовательность целых чисел, заканчивающаяся нулем и содержащая еще один нуль в произвольном месте. Написать программу, которая подсчитывает количество чисел между нулями.
19. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, которая выводит последнее ненулевое число последовательности.
20. Дано целое число N (>0). Если оно является степенью числа 3, то вывести true, если не является – вывести false.
21. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, находящую максимальное число последовательности.
22. Написать программу, определяющую количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N (>0).
23. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, выводящую все числа последовательности, кратные трем.
24. Как и многие другие девочки, Маша любит разные гадания. Некоторое время назад Маша узнала новый способ гадать на числах – для какого-нибудь интересующего ее натурального числа N надо посчитать сумму всех чисел, на которые N делится без остатка. Маша не очень любит арифметику, и попросила вас написать программу, которая автоматизирует процесс гадания.
Ввод: натуральное число N (N ≤ 1000).
Вывод: сумма всех натуральных делителей числа N.
25. Петя и Катя – брат и сестра. Петя – студент, а Катя – школьница. Петя помогает Кате по математике. Он задумывает два натуральных числа X и Y (X,Y≤1000), а Катя должна их отгадать. Для этого Петя делает две подсказки. Он называет сумму этих чисел S и их произведение P. Помогите Кате отгадать задуманные Петей числа.
Ввод: два натуральных числа S и P, разделенные пробелом.
Вывод: два числа Х и Y, загаданные Петей. Числа следует вывести в порядке неубывания своих значений, разделенные пробелом.

26. Даны два натуральных числа A и B. Требуется найти их наибольший общий делитель (НОД).

Ввод: натуральные числа A и B через пробел (A, B ≤ 109).

Вывод: НОД чисел А и В.

Информатика (15 баллов) | 38 просмотров
0

Пожайлуста сделайте ещё !!!1

Дан 1 ответ
0 голосов
Правильный ответ

Var
    N, s, i: Integer;
    s1: real;

begin
    readln(N); {общий ввод для всех задач}
    
    if N < 0 then
        writeln('Задача 1. N=', 0)
    else writeln('Задача 1. N=', N + 4);
    
    s := 0;
    for i := 1 to n do
        s := s + i;
    writeln('Задача 7. 1+2+3+…+N=', s);
    
    write('Задача 9. Последовательность от N до 1 = ');
    for i := n downto 1 do
        write(i, ' ');
    writeln();
    
    s1 := 0;
    for i := 1 to n do
        s1 := s1 + i / 10;
    writeln('Задача 12. 0,1+0,2+0,3+..+N/10=', s1);
    
    write('Задача 13. Последовательность квадратов от 1 до N = ');
    for i := 1 to n do
        write(i * i, ' ');
    writeln();
    
    write('Задача 14. Последовательность первых N нечетных чисел = ');
    for i := 1 to n do
        write(2 * i - 1, ' ');
    writeln();
    
    if N > 0 then
        writeln('Задача 20. N степень 3 = ', frac(ln(n) / ln(3)) = 0);
    
    s := 0;
    for i := 1 to n do
        if n mod i = 0 then
            s := s + i;
    writeln('Задача 24. Сумма всех натуральных делителей числа N (сключая 1 и N) = ', s);
end.

(55.0k баллов)