Дано целое число c.Напишите программу,которая возводит в квадрат частное от...

0 голосов
64 просмотров

Дано целое число c.Напишите программу,которая возводит в квадрат частное от целочисленного деления числа с на 5 и выводит на экран монитора результат)


Информатика (111 баллов) | 64 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
c: integer;
begin
read(c);
writeln(sqr(c div 5));
end.

(668 баллов)
0

спасибо,а что значит "sqr"?

0

это функция возведения в квадрат выражения.

0

а зачем здесь div?

0

это функция целочисленного деления.

0

спасибо ещё раз)

0 голосов

Program del;
var p, s: integer;
begin
writeln('Введите делимое'); readln(p);
s:= sqr(p mod 5);
Writeln('Остаток в квадрате =', s);
end.

(56 баллов)
0

там частное надо возводить, а не остаток. плюс, ты задействуешь лишние переменные, что, несомненно, задействует больше памяти, а это всегда не очень хорошо для программы ~~

0

не mod, а div . Условие неверн опрочитал

0

прочитал