Дано целое число A, значение которого вводится с клавиатуры. Написать программу, которая...

0 голосов
48 просмотров

Дано целое число A, значение которого вводится с клавиатуры. Написать программу, которая выводит на экран

true , если A не кратно трем и оканчивается нулем

false в противном случае.


Информатика (55 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a:integer;
begin
 readln(a);
 if ((a mod 3 <>0) and (a mod 10 = 0) and (a div 10>0)) or (a=0) then
  writeln ('true') 
 else writeln ('false');
end.

(56 баллов)