Написать программу ** языке Pascal для вычисления y=1/cosx+ln|tg(x/2)|+(A+B(x))/(C+D(x))...

0 голосов
99 просмотров

Написать программу на языке Pascal для вычисления
y=1/cosx+ln|tg(x/2)|+(A+B(x))/(C+D(x))
Помогите пожалуйста


Информатика (109 баллов) | 99 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
uses crt;
var
y,a,b,c,d: Integer;
x: real;
begin
clrscr;
write('x='); readln(x);
write('a='); readln(a); 
write('b='); readln(b); 
write('c='); readln(c); 
write('d='); readln(d); 
y:= 1 / cos(x) + ln(abs(tan(x / 2)) + (a + b *x) / (c + d *x));
write('y=',y:0:4);  
end;
readln
end.
Наверное так...
(985 баллов)
0

var
x,a,b,c,d: Integer;
y: real; 
вот так

0

Спасибо большок

0

ты гений