Написать программу которая сформирует массив следующим образом: A[1]=-1 A[2]=1 A[3]=-2...

0 голосов
28 просмотров

Написать программу которая сформирует массив следующим образом:
A[1]=-1 A[2]=1 A[3]=-2 A[4]=2 A[5]=-3 A[6]=3 A[7]=-4


Информатика (15 баллов) | 28 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a:array[1..7] of integer;
ar,b,c:integer;
begin;
ar:=1;
b:=1;
for c:=1 to 7 do
begin;
ar:=-1*ar;
a[c]:=ar;
writeln(a[c]);
if ar>0 then
ar+=1;
end;
end.

(38.6k баллов)
0

ar+=1; может ar:=1; ?

0

Нет. Это выражение равно ar:=ar+1