Я написала программу, но там где то ошибка, решение не верное выходит, помогите найти...

0 голосов
29 просмотров

Я написала программу, но там где то ошибка, решение не верное выходит, помогите найти ошибку. Вот задание: Написать программу, подсчитывающую среднее арифметическое всех элементов массива.
var i,n:integer;
g: real;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
begin
write ('введите ',i,'элемент');
read(a[i]);
end;
n:=0;
for i:=1 to 10 do
n:=n+a[i];
write (n);
g:=n/10;
write (g);
end.


Информатика (233 баллов) | 29 просмотров
0

write (n); - уберите эту строку и все у Вас получится

0

Оно и так работает, просто склеивает два числа в одно

Дан 1 ответ
0 голосов

У Вас всё считает правильно, но рекомендую Вам изучить вопрос: "В чем отличие между Write и Writeln?"
При выводе добавьте "ln"

(5.1k баллов)