Написать программу ввода целых чисел до тех пор, пока не будет введен ноль, посчитать...

0 голосов
129 просмотров

Написать программу ввода целых чисел до тех пор, пока не будет введен ноль, посчитать сумму введеных чисел и их среднее арифметическое. помогите пожалуйста!


Информатика (19 баллов) | 129 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var sum,n,temp:integer;

begin

   sum:=0;

   n:=0;

   readln(temp);

   while(temp<>0) do begin

      inc(n);

      sum:=sum+temp;

      readln(temp);

   end;

   writeln('Sum = ',sum,'; Ave = ',sum/n)

   end.

(148k баллов)