За 8 класс Решите задачу: Напишите программу, вычисляющую и выводящую ** экран число...

0 голосов
113 просмотров

За 8 класс
Решите задачу: Напишите программу, вычисляющую и выводящую на экран число бит, если задано число Мбайт. Количество Мбайт запрашивайте у пользователя программы.


Информатика (132 баллов) | 113 просмотров
0

На каком языке?

0

В паскале

0

поможешь?

0

спасибо

0

Пожалуйста

0

добавь меня в др

0

плиз

0

Добавил

0

спасибо

0

от дущи братан душа в душу

Дан 1 ответ
0 голосов
Правильный ответ

Программа на паскале:
var n: integer;
begin
  write('Введите число Мбайт: ');
  readln(n);
  write(n, ' Мбайт = ', 1024 * 1024 * 8 * n, ' бит');
end.

(13.3k баллов)
0

Неверно, надо 1024*1024*8

0

И потом, мегабайты могут быть и нецелыми.

0

Да, в последнее время стал очень невнимательным. Спасибо за поправку. В задании не уточнили входные данные, и я принял их за целые числа