HELP!!!!! дан двумерный массив(4*5) написать программу, которая определит кол-во четных...

0 голосов
93 просмотров

HELP!!!!!
дан двумерный массив(4*5)
написать программу, которая определит кол-во четных элементов двумерного массива. Заполонить с клавиатуры.


Информатика (1.1k баллов) | 93 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Программа внутри вложенного файла


image
(6.9k баллов)
0 голосов

Var a:array[1..10, 1..10] of integer; 
i,j,k:integer; 
begin 
k:=0; 
for i:=1 to 4 do 
for j:=1 to 5 do begin 
readln(a[i,j]); 
if (a[i,j] mod 2=0) then k:=k+1; 
end; 
for i:=1 to 4 do begin 
for j:=1 to 5 do 
write(a[i,j],' '); 
writeln; 
end; 
writeln('Количество четных элементов - ',k); 
end.

(1.9k баллов)
0

у Вас 5 строчек, 4 столбца

0

Виноват, ошибочка)

0

а я не выводила на печать элементы, поскольку их сам вводит пользователь, значит, он их видит. С точки зрения ЕГЭ лишнее писать даже вредно. Расход памяти :))