Задача:Написать программу,которая вычисляет сколько часов,минут,сек.,в...

0 голосов
86 просмотров

Задача:Написать программу,которая вычисляет сколько часов,минут,сек.,в n-кол-во;дней,недель,месяцев.Моя проблема в том,что я не знаю как соединить 3 процедуры в 1 основную программу или что сделать, чтобы в основной программе находилось 3 процедуры,а сам принцип решения я знаю,на присланном фото есть решение n-кол-лво дней,также можно отдельно для остальных,но нужно чтобы было все в 1 проге.Помогите пожалуйста!


image

Информатика (1.8k баллов) | 86 просмотров
0

Паскаль

0

)))

0

А на фото и есть паскаль ))

0

Turbo 7.0

0

не грузит фото)

0

странно

0

ну хоть есть

0

интернет медленный у меня

0

А решал я через процедуру

0

может загрузит

Дан 1 ответ
0 голосов
Правильный ответ

Если n - количество месяцев, то для точного расчета нужно знать какие это месяцы (количество дней в месяцах различно). Если упрощенно считать, что в месяце 30 дней, то программа будет такой:
Program Pkek;
var n,h,m,s:longint;
Procedure Day(n1:integer; var h1,m1,s1:longint);
begin
h1:=n1*24;
m1:=n1*60*24;
s1:=n1*360*24;
end;
Procedure Week(n1:integer; var h1,m1,s1:longint);
begin
h1:=n1*24*7;
m1:=n1*60*24*7;
s1:=n1*360*24*7;
end;
Procedure Month(n1:integer; var h1,m1,s1:longint);
begin
h1:=n1*24*7*30;
m1:=n1*60*24*7*30;
s1:=n1*360*24*7*30;
end;
begin
writeln('Введите целое число n:');
readln(n);
Day(n,h,m,s);
writeln('Если ',n,' - число дней, то:');
writeln('h=',h,'  m=',m,'  s=',s);
Week(n,h,m,s);
writeln('Если ',n,' - число недель, то:');
writeln('h=',h,'  m=',m,'  s=',s);
Month(n,h,m,s);
writeln('Если ',n,' - число месяцев, то:');
writeln('h=',h,'  m=',m,'  s=',s);
end.

Введите целое число n:
7
Если 7 - число дней, то:
h=168  m=10080  s=60480
Если 7 - число недель, то:
h=1176  m=70560  s=423360
Если 7 - число месяцев, то:
h=35280  m=2116800  s=12700800

(194k баллов)