Написать программу ** языке Паскаля для вычисления S=1^1+2^2+3^3+...+n^n

0 голосов
43 просмотров

Написать программу на языке Паскаля для вычисления S=1^1+2^2+3^3+...+n^n


Информатика (12 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

var
  n, i: integer;
  s: real;
begin
  readln(n);
  for i := 1 to n do
    s := s + exp(i*ln(i));
  writeln(s);
end

(1.1k баллов)