Напишите программу, которая находит среди элементов массива, состоящего из n элементов,...

0 голосов
45 просмотров

Напишите программу, которая находит среди элементов массива, состоящего из n элементов, наименьший элемент и его порядковый номер.


Информатика (12 баллов) | 45 просмотров
Дан 1 ответ
0 голосов

Var
a:array[1..1000000]of integer;
i,min,n,c:integer;
   begin
      readln(n);
      for i:=1 to n do
      begin
       read(a[i]);
         if i = 1 then
         min:=a[i];
       if a[i]        begin
       min:=min+a[i] ;
       a[i]:=min - a[i];
       min:=min - a[i];
         c:=i;
         end;
      end;
    writeln('a[',c,']=',min);
    end.

(2.3k баллов)