Написать программу, считающую сумму цифр целого числа. программа должна быть написана в...

0 голосов
43 просмотров

Написать программу, считающую сумму цифр целого числа. программа должна быть написана в TP(Turbo Pascal)


Информатика | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

program z1;
var S,n:integer;
begin
writeln('Введите число');
readln(n);
while n>0 do begin
S:=S+n mod 10;
n:=n div 10;
end;
writeln('S=',S);
end.

(1.2k баллов)