В Паскале с помощью repeat. Составьте программу, которая выводит ** экран сумму нечетных...

0 голосов
51 просмотров

В Паскале с помощью repeat. Составьте программу, которая выводит на экран сумму нечетных чисел от 36 до 66.


Информатика (16 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Begin
  Writeln(((65+37)*((65-37) div 2 +1)) div 2);
end.

Или более универсально:
Var A,B : Integer;
Begin
  Readln(A,B);
  Inc(A,Ord(not Odd(A)));
  Dec(B,Ord(not Odd(B)));
  Writeln(((B+A)*((B-A) div 2 +1)) div 2);
end.

А если строго по заданию, то так:
Var S,i : Integer;
Begin
  s:=0; i:=37;
  Repeat
    s:=s+i;
    Inc(i,2);
  Until i>65;
  Writeln(s);
end.

(5.1k баллов)