Program HFi; var a,b:integer;С,F:real; begin writeln('Введіть значення а'); read(a);...

0 голосов
101 просмотров

Program HFi;
var a,b:integer;С,F:real;
begin
writeln('Введіть значення а');
read(a);
writeln('Введіть значення b');
read(b);
writeln('Введіть значення С');
read(С);
writeln('Фаренгейт Цельсій');
for a:=1 to b do begin F:=1.8*C+32;writeln(F:4,C:15:2) end;readln;
end.
Неожиданный символ "С" строка 2


Информатика (101 баллов) | 101 просмотров
0

Подозреваю, что в формуле "С" не в латинской раскладе написали.. Попробовал у себя, измнение С на латинское решило проблему

Дан 1 ответ
0 голосов

Вот
var a,b:integer;    
c,f:real;
begin
writeln('Введіть значення а');
read(a);
writeln('Введіть значення b');
read(b);
writeln('Введіть значення С');
read(c);
writeln('Фаренгейт Цельсій');
for a:=a to b do begin 
F:=1.8*c+32;
writeln(f:4,C:15:2)
end;
readln;
end.

(4.2k баллов)
0

Что должно различатся? Это табуляция ф-и я так понял?

0

Вам надо добавить "крок=1"

0

куда?

0

можешь написать программу?

0

пожалуйста

0

сейчас

0

ок

0

const h=1;
var a,b:integer; 
    c,f:real;
begin
writeln('Введіть значення а');
read(a);
writeln('Введіть значення b');
read(b);
writeln('Введіть значення С');
read(c);
writeln('Фаренгейт Цельсій');
for a:=a to b do begin 
f:=1.8*c+32;
writeln(f:4:2,'      ',c:4:2);
c:=c+h;
end;
readln;
end.

0

Спасибо,всё работает)))

0

=)