Паскаль. Нужно написать программу ** паскале, вещественный тип обработки данных ...

0 голосов
47 просмотров

Паскаль.
Нужно написать программу на паскале, вещественный тип обработки данных
Нахождения номера наименьшего наименьшего элемента в массиве заданной длины среди всех положительных элементов длина массива вводится с клавиатуры


Информатика (20 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Исходник и пример работы в приложении к ответу


image
(1.8k баллов)
0

спасибо большое!

0

Что и относительно чего иначе?) А вообще - пожалуйста

0

подождите немного я немогу прикрепить ни файла ни ссылки

0

VAR
A :array[1..50] of integer;
m,i,min,Num :integer;
Fout :text;
BEGIN
repeat
writeln('Введите длину массива');
readln(m);
if m<=1 then<br>writeln('В массиве должно быть как минимум, больше одного элемента');
until m>1;
min:=32767;
For i:=1 to m do
begin

0

writeln('введите элемент массива');
readln(a[i]);
if (A[i]>0) then begin
if(a[i])min:=A[i];
Num:=i;
end;
end
Else writeln('Элементы должны быть положительные');
end;
writeln('Номер наименьшего',Num);
begin
Assign(Fout,'MASSIV.RES')

0

ReWrite(Fout);
writeln(Fout,'Isxodnyi massiv iz ',m,' elementov');
for i:=1 to m do
begin
write(Fout,A[i]:11);
if i mod 5 = 0 then writeln(Fout);
end;
end;
Close(Fout);
END.

0

Много-много кода, вот честно скажу лень разбираться дотошно.. По первому взгляду, если позволите, несколько замечаний..

0

1. Вы создаёте статический массив размерность 50 элементов. Какое бы число вы не вводили в качестве размерности, на самом деле она не изменится. Однако если вы превысите размерность, например укажете 51, то на вводе 51-ого элемента вылетите с ошибкой "превышение границ массива".. скорее всего

0

2. Да и просто вводить руками 50 элементов, или сколько там требуется.. кошмар кромешный)

0

Так точно! спасибо!