Написать программу ** языке Паскаль(ABC) для решения простого линейного уравнения

0 голосов
72 просмотров

Написать программу на языке Паскаль(ABC) для решения простого линейного уравнения


Информатика (99 баллов) | 72 просмотров
Дан 1 ответ
0 голосов

//ax + b = 0,   где а и b – любые числа.
var a,b,x:real; //инициализирует переменные a,b и x типа real, с плавающей точкой
begin; //начало программы
readln(a); //ввод a
readln(b); //ввод b
x:=-b/a;   //находим корень
writeln(x); //выводим корень
end.        //конец программы

(1.7k баллов)
0

//ax + b = 0, где а и b – любые числа.
var a,b,x:real;
begin;
readln(a);
readln(b);
x:=-b/a;
writeln(x);
end.

0

не тоэ

0

Program1.pas(4) : Ошибка времени выполнения: Input string was not in a correct format.

0

Ах, тебе нужно, чтобы уравнение было введено одной строкой?

0

да

0

Тогда всё намного веселее. Сейчас что-нибудь придумаю.

0

ну как там ?

0

Всё сложно. Программа выше решает уравнения типа ax + b = 0, это и есть простые линейные уравнения. Но в ней нужно вводить a и b, а не всё уравнение. Сложность извлечением из строки уравнения заключается в двух пунктах. Во-первых, сложно извлекать действия, на моём уровне это скорее невозможно. Во-вторых, пользователю предоставляется слишком большая вариативность действий, что влечёт за собой большое количество исключений. Никогда не думала, что мне придётся извлекать уравнение из строки.

0

*Сложность  с извлечением

0

спасибо