Написать программу определения стоимости разговора по телефону с учетом скидки 20%...

0 голосов
102 просмотров

Написать программу определения стоимости разговора по телефону с учетом скидки 20% представляемой по субботам и воскресениям.


Информатика (129 баллов) | 102 просмотров
Дан 1 ответ
0 голосов

Var st:real;
    mn:integer;
    d:1..7;
begin
write('Введите стоимость 1 минуты в рублях st=');
readln(st);
write('Введите продолжительность разговора в минутах mn=');
readln(mn);
repeat
write('Введите номер дня недели d=');
readln(d);
until d in [1..7];
case d of
1..5:st:=st*mn;
else st:=st*mn*0.8;
end;
write('Стоимость разговора=',st:0:2);
readln
end.

(904 баллов)
0

Спасибо,можешь на писать программу на листочке и сфоткать а то че-то так не понятно.