помогите, пожалуйста, решить задачу... написать программу ** языке Паскаль Продав...

0 голосов
39 просмотров

помогите, пожалуйста, решить задачу...

написать программу на языке Паскаль

Продав квартиру, вы получили 22000 долларов и положили их в банк. Банк начисляет 18% в первый месяц, а каждый следующий - тоже 22%, но уже с общей суммы с учётом начисленных процентов. Сколько денег будет в банке на вашем счету через год? (Нестабильностью нашей экономической системы пренебрегаем)


Информатика (12 баллов) | 39 просмотров
Дано ответов: 2
0 голосов

var
  i: integer;
  s: real;
begin
  for i := 1 to 12 do begin
    if(i = 1) then s := 22000 + (22000 * 0.18) else
    s := s + (s * 0.22);
  end;
  writeln(s:0:3);
end.

(1.1k баллов)
0 голосов

В принципе, решение формально арифметически правильное. НО ведь задача нереальна.

1. Как правило, резидентам законодательно запрещено осуществлять на территории своего государства сделки не в валюте государства, значит эта сделка была либо серой(на бумаге одно, в реале другое), либо сделка осуществлялась на территории другого государства, где покупатель был нерезидентом.

2. Таких ОГРОМНЫХ процентов по депозитным валютным вкладом НЕ СУЩЕСТВУЕТ В ПРИНЦИПЕ,  это же около 300% годовых в валюте! Это под какие же процены банк должен выдавать кредиты, чтобы привлечённые ресурсы были рентабельные, да и кто их под такие проценты возьмёт!. Реальные проценты по депозитным вкладам 5-10% ГОДОВЫХ.

 

Я не случайно написал этот комментарий, ведь если по физике вам предложат задачу, ну например, такую "Сколько времени продлится полет на Марс, если расстояние до него 60000000км, а скорость космолёта 500000км/с", вы ведь не будете её решать, потому что такой скорости не может быть. Так и здесь: таких процентов не может быть! Поэтому решать такую задачу нельзя, она описывает не существующие объекты(ситуацию).

 

Вот и всё!

Успехов!