59 БАЛЛОВ ЗА ПОЛНОЕ РЕШЕНИЕ! Нужно составить программу ** PascalABC.NET и сделать все как...

0 голосов
36 просмотров

59 БАЛЛОВ ЗА ПОЛНОЕ РЕШЕНИЕ! Нужно составить программу на PascalABC.NET и сделать все как на скришоте ниже.


image

Информатика (31 баллов) | 36 просмотров
0

Требуется от учителя, не моя прихоть

0

ой

0

Ах, поймет... ну ладно, устроим ему "проверку на вшивость".

0

Нет он то поймет так как, мы работаем и он сам работает в ABC.NET а что бо мы не списывали он дает задачки из разных учебников.

0

Модет и не главное, но ясно одно с таким подходом: если написать так, как пишут сейчас на ABC.NET в его последней версии, Ваш учитель скорее всего даже не поймет этого решения.

0

описка. Не дела, а "баллы"

0

Ну тут не главное написать как в условие просто надо чтобы выполнялись условия которые заданы в задаче

0

А это не комиссия. Ваши потраченные дела делятся пополам, потому что ответы могут дать двое.

0

Вот пусть Ваш учитель сам пишет программы от Турбо Паскаля в ABC.NET

0

если честно я не думал что есть как бы комиссия

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
program massiv;
const
  n=5;
type
  V=array[1..n] of real;

procedure vvod_vand(var A:V; n:integer);
begin
  Randomize;
  for var i:=1 to n do A[i]:=20*Random
end;

procedure vvod(var B:V; n:integer);
begin
  Writeln('Введите элементы массива');
  for var i:=1 to n do Read(B[i])
end;

function sred(var D:V):real;
begin
  Result:=D.Average;
end;

var
  a:V;
begin
  var f:=OpenWrite('myfile.txt');
  vvod(a,n);
  Writeln(f,'Введенные элементы массива');
  foreach var c in a do Write(f,c,' '); Writeln(f);
  Writeln('Среднее: ',sred(a));
  Writeln(f,'Среднее: ',sred(a));
  Writeln('Случайные числа');
  Writeln(f,'Случайные числа');
  vvod_vand(a,n); a.Println(', ');
  foreach var c in a do Write(f,c,' '); Writeln(f);
  Writeln('Среднее: ',sred(a));
  Writeln(f,'Среднее: ',sred(a));
  f.Close
end.

Тестовое решение:
Введите элементы массива
3 5.2 -3.7 6 -1.112
Среднее: 1.8776
Случайные числа
11.5666489450106, 6.30297457161498, 6.51701744949306, 10.1566330204516, 18.8177900010803
Среднее: 10.6722127975301

(142k баллов)
0

Не получается, ладно ждем вас

0

Изменил, как Вы просили

0

Почему же. смотрите содержимое созданного файла

0

Только вы не доделали 5 пункт

0

Ответьте в ЛС

0

Получилось

0

Читайте личное сообщение

0

Опять не вышло?

0

Пробуйте

0

Спасибо большое очень выручили!!!