Помогите срочно ребят!!!!!! Требуется написать программу для перевода целых чисел из восьмеричной системы счисления в десятичную.
Var o,d,k,l: integer; begin read(o); d := 0; k := 1; l := 1; while l <= o do<br> begin d := d + k*(o div l mod 10); l := l * 10; k := k * 8 end; writeln(d) end.