написать программу в Pascal и составить её блок -схему: по возрасту, введённому с...

0 голосов
226 просмотров

написать программу в Pascal и составить её блок -схему: по возрасту, введённому с клавиатуры, определить, к какой возрастной группе относится человек: от 0 до 7 лет дошкольник. от 8 до 17 лет школьник, от 18 до 23 лет студент, 24-55 лет работник, от 56 лет и старше пенсионер.


Информатика (22 баллов) | 226 просмотров
Дано ответов: 2
0 голосов

var

  a:integer;

begin

  write('Введите возраст '); readln(a);

  write('Этот человек ');

  case a of

    0..7: writeln('дошкольник');

    8..17: writeln('школьник');

    18..23: writeln('студент');

    24..55: writeln('работник');

    else

     writeln('пенсионер');

  end;

end.


image
(3.1k баллов)
0 голосов

var
l:integer;
begin
writeln('skolko let?');
readln(l);
if (l>=0) and (l<=7) then</span>
writeln('Doshkolnik')
else if (l>=8) and (l<=17) then</span>
writeln('shkolnik')
else if (l>=18) and (l<=23) then</span>
writeln('student')
else if (l>=24) and (l<=55) then</span>
writeln('rabotnik')
else if l>=56 then
writeln('pensioner');
end.

(3.4k баллов)