Помогите написать программу ** Паскале плиз: №11 и 12

0 голосов
25 просмотров

Помогите написать программу на Паскале плиз:
№11 и 12


image

Информатика (12 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

11.var ma:array of array of integer;
m,n,maxi,maxj,max,i,j,maxr:integer;
begin;
randomize;
readln(n);
readln(m);
max:=-214;
setlength(ma,n+1);
for i:=1 to n do
setlength(ma[i],m+1);
writeln('Matrix:');
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to m do
    begin;
     ma[i,j]:=random(41)-20;
     write(ma[i,j]:4);
     if abs(ma[i,j])>max then
      begin;
       max:=abs(ma[i,j]);
       maxr:=ma[i,j];
       maxi:=i;
       maxj:=j;
      end;
    end;
 end;
writeln;
writeln('Max:',maxr,' столбец:',maxj,' строка:',maxi);
end.
12.
var x,y,d,z:real;

function max(a,b:real):real;
begin;
if a>b then max:=a else max:=b;
end;

function min(a,b:real):real;
begin;
if aend;

begin;
readln(x);
readln(y);
readln(d);
z:=(max(x,y)+15*x)/(1.1+sqr(max(x-d,y-d)))-1;
writeln(z);
end.

(1.7k баллов)