Помогите написать программу для нахождения НОД ABC Pascal

0 голосов
21 просмотров

Помогите написать программу для нахождения НОД ABC Pascal


Информатика | 21 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
  a,b:integer;
begin
  Read(a,b);
  while a <> b do
    if a > b then a := a - b
    else b := b - a;
  Writeln(a)
end.

(142k баллов)
0

Еще бы алгоритм Евклида не работал! Он тысячелетиями проверен)))

0 голосов

Var a,b,nod:integer;
begin
readln(a,b);
if a>=b then nod:=a mod b else nod:=b mod a;
writeln(nod)
end.

(192 баллов)