Как на Pascal ABC написать программу, которая будет считать сумму цифр числа, введенного с клавиатуры? Количество цифр в числе неизвестно! Число целое. Очень желательно с объяснениями (вне программы). Заранее спасибо!!! P.S. Я дам 15 баллов! Очень нужно!!!
И зачем второй раз писать одно и то же?
Вообще задача звучит не так.
Мне не помогли, а с момента как я задала вопрос, прошло около часа. Поэтому я сделала ещё одну попытку.\
Вам и комментарии написали, и решение дали....
65 минут назад дали решение....
А еще - на надо про баллы, если Вы не понимаете систему их распределения. Вы 15 баллов не даете, а тратите. Даете каждому. кто решает задание, только половину...
через 5 мин всё будет :D
Program LOL2016; var n,s,r:integer; begin readln(n); s:=0; while(n <> 0) do begin r:=n mod 10; s:=s+r; n:=n div 10; end; writeln(s); end. если что то не понятно просто спроси и я обьясню :)