Написать программу с ветвлением в ПАСКАЛЕ
var x,y,a,d:real; begin readln(d); readln(x); if d<0 then begin<br>writeln('net resheniy'); exit; end; a:=sqrt(d); if x>=a then y:=sin(x)+a else if (x>0) and (xy:=sqrt(x)+a*a else writeln('net resheniy'); writeln(y); end.
var x,y,a,d:real; label 1,2; begin 1:write('Введите d (больше нуля): '); readln(d); if (d<=0) then begin writeln('Введите другое значение d'); goto 1; end;<br>a:=sqrt(d); 2:write('Введите x (больше нуля): '); readln(x); if x<=0 then begin writeln('Введите другое значение x '); goto 2; end;<br>if x>=a then y:=sin(x)+a; if xwriteln('Значение функции y равно ',y); end. Насколько я понял, вводятся две переменные: d и x (а находится из d, значение функции - из всех остальных).
Если введённое значение переменных не удовлетворяет условию x>0 и d>0, то программа заставит ввести значения снова.