СРОЧНО!! Написать программу, которая вводит три числа – А, В, С и распечатывает только...

0 голосов
38 просмотров

СРОЧНО!!
Написать программу, которая вводит три числа – А, В, С и распечатывает только те из них, которые КРАТНЫ 3 и ОКАНЧИВАЮТСЯ на 5. Если таких чисел нет, напечатать слово НЕТ.

Например, если введены числа: 15, 25, 45, то распечатаны должны быть числа 15 и 45.
Если введены числа 15, 60, 25, то распечатано должно быть только число 15.
Если введены числа 14, 25, 60, то должно быть напечатано слово НЕТ.


Информатика (39 баллов) | 38 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;
k:boolean;
begin
readln(a);
readln(b);
readln(c);
k:=false;
if (a mod 3=0) and (a mod 10=5) then
 begin;
 writeln(a);
 k:=true;
 end;
if (b mod 3=0) and (b mod 10=5) then
 begin;
 writeln(b);
 k:=true;
 end;
if (c mod 3=0) and (c mod 10=5) then
 begin;
 k:=true;
 writeln(c);
 end;
if k=false then writeln('НЕТ');
end.

(1.7k баллов)
0

Забыла про НЕТ...

0

Можешь в комментарии написать?

0

Уже исправила.

0

Спасибо))))