Срочно!! Написать программу решения следующей задачи: Найти, какое расстояние будет через...

0 голосов
103 просмотров

Срочно!! Написать программу решения следующей задачи:
Найти, какое расстояние будет через t часов между двумя автомобилями, которые едут в разные стороны, причем первый со скоростью V1, а второй со скоростью V2. Учтите, что в момент отправления расстояние между автомобилями было равно S.


Информатика (39 баллов) | 103 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
var t, v1, v2, s: real;
begin
  write('t = ');
  read(t);
  write('v1 = ');
  read(v1);
  write('v2 = ');
  read(v2);
  write('S = ');
  read(s);
  write(s + (v1 + v2) * t)
end.
За время t автомобили пройдут расстояние (v1 + v2) * t. Значит они окажутся на расстоянии s + (v1 + v2) * t 
(13.3k баллов)
0 голосов

Qbasic:
cls
input "скорость 1", v1
input "скорость 2", v2
input "расстояние", s
input "время", t
s1 = v1 * t
s2 = v2 * t
otvet = s1 + s2 + s
print otvet

(245 баллов)
0

если по русски:

0

Эх, надо паскаль(( сорь

0

ввод всех данных

0

потом новая переменная = пройденный путь первой машины, второй новой переменной = путь второй машины, складываешь полученные расстояния и первоначальное расстояние

0

хотя по тому что ты написал я в паскале напишу, спасибо))

0

незачто. просто я бейсик в детстве выучил, а программирование (на паскале) мы не проходили ни в школе, ни в колледже.

0

а так бейсик очень легкий и функциональный одновременно