Написать программу в с++

0 голосов
30 просмотров

Написать программу в с++


image

Информатика (330 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
//PRE: int a[] of size 30 is filled
#include
int main()
{
     float summ = 0.0;
     int numberOfStudentsWhoPassed = 0;
     for (int i = 0; i < 30; ++i)
     {
           if (a[i] > 20)
           {
                 summ+= a[i]; ++numberOfStudentsWhoPassed;
           }
     }
     std::cout << "Average is " << summ/numberOfStudentsWhoPassed << endl;<br>}


(1.2k баллов)
0

Спасибо!!!!!!! Умница!!!!!!