написать программу в паскале которая вставит между буквами введенного слова пробел

0 голосов
67 просмотров

написать программу в паскале которая вставит между буквами введенного слова пробел


Информатика (20 баллов) | 67 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

var
    s, s_new: string;
    i: integer;

begin
    read(s);
    for i := 1 to length(s) do
        s_new := s_new + s[i] + ' ';
    writeln(s_new);
end.

(53.1k баллов)
0 голосов

 Program BlankWord;

Uses Crt;

var s1:string;

        l:integer;

begin

     clrscr;

     write('Введите Слово:');

     readln(s1);

     l=length(s1);

 

     for i:=l downto 1 do
         if(i mod 2 = 0)then
              Insert(' ', s1, i);
              writeln(s1);
              readkey;

     

 end.

 

 

(2.4k баллов)