Напишите программу которая определяет является ли число простым.

0 голосов
63 просмотров

Напишите программу которая определяет является ли число простым.


Информатика (12 баллов) | 63 просмотров
Дан 1 ответ
0 голосов

Program PrimeNumber;

Uses Crt;

var i,f,n:integer;
begin

     clrscr;
      write('Введите число:');
      readln(n);

      f:=0;  
      for i:=2 to trunc(sqrt(n)) do
              if (n mod i)=0 then f:=1;
      if (f=0) then writeln('Число является простым')

                     else writeln('Число не является простым');
      readkey;
end.

 

 

(2.4k баллов)