Помогите. Pascal abc Написать программу, которая находит сумму целых чисел ,которые...

0 голосов
48 просмотров

Помогите. Pascal abc
Написать программу, которая находит сумму целых чисел ,которые больше 100, меньшее 200, кратны 7 и заканчиваются на 1 или 4


Информатика (15 баллов) | 48 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a2,a,c,sym:
integer;
begin
for a:=100 to 200 do begin
  a2:=a;
  while (a2<>0) do begin
    c:=a2 mod 10;
    a2:=a2 div 10;
  end;
  if (a mod 7 = 0 ) and ((c=1) or (c=4)) then sym:=sym+a;
  end;
  writeln('сумма чисел от sym=',sym);
end.

(8.6k баллов)
0 голосов
var sum, i : integer;
begin    
for i := 100 to 200 do  
    if (i mod 7 = 0) and ((i div 100 = 4) or (i div 100 = 1)) then          sum := sum + i;    writeln('Сумма равна ', sum)
end.
(564 баллов)
0

там же числа от 100 до 200

0

сори 

0

туплю

0

далее, в if  скобку пропустил, вместо 10 в условии (div 10) напиши div 100

0

вот так правильно будет

0

var sum, i : integer; 
begin    
for i := 100 to 200 do   
    if (i mod 7 = 0) and ((i div 100 = 4) or (i div 100 = 1)) then          sum := sum + i;    writeln('Сумма равна ', sum) 
end.

0

а так, классное решение, я вот затупил, через while пошол решать, муторно получилось и процессор грузит