Задача банкомат Написать программу: ** вход подаётся число s. Выразить данную сумму денег...

0 голосов
49 просмотров

Задача банкомат
Написать программу:
На вход подаётся число s. Выразить данную сумму денег минимальным количеством банкнот по 500, 100, 10, 5, 2,1.


Информатика (87 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program abc;
var a:array[1..6] of integer;
var i,s: integer;
begin
 i:=0;a[1]:=500;a[2]:=100;a[3]:=10;a[4]:=5;a[5]:=2;a[6]:=1;
writeln('Введите целое число,сумму денег:');
readln(s);
while s<>0 do
begin
if s>=a[1] then begin
s:=s-a[1]; i:=i+1; end;
if (s>=a[2]) and (sif (s>=a[3]) and (sif (s>=a[4]) and (sif (s>=a[5]) and (sif (s>=a[6]) and (send;
Writeln('Наименьшее число купюр =',i);
end.

(1.4k баллов)