Помогите написать программу ** паскале абс цикл с постусловием Дано целое число N (> 1)....

0 голосов
60 просмотров

Помогите написать программу на паскале абс
цикл с постусловием
Дано целое число N (> 1). Вывести наименьшее из целых чисел K, для которых сумма
1 + 2 + … + K будет больше или равна N, и саму эту сумму.


Информатика (35 баллов) | 60 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var n,k,summ:integer;
begin
  write('Введи число N: ');
  readln(n);
  repeat begin
     k:=k+1;
     summ:=summ+k;
     end;
  until summ>=n;
  writeln('K=',k,', 1+..+',k,'=',summ,', ',summ,'>=',N);
end.  

(3.3k баллов)
0

можете еще и описать?

0

тут и описывать-то нечего, всё очевидно... Если вы не понимаете, что тут происходит, то настоятельно советую почитать книгу по вашему предмету. Дальше задачи сложнее будут, а эта просто элементарная была...

0

спасибо