1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в...

0 голосов
140 просмотров

1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последова¬тельность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число — сумму чисел, кратных 3 и не кратных 6, встречающихся с последовательности. Пример работы программы: Входные данные Выходные данные 12 1 15 30 4 2 0


Информатика (198 баллов) | 140 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
a, n: integer;
begin
n:=0;
repeat
readln(a);
if (a mod 3 = 0) and (a mod 6 <> 0) then
inc(n, a);
until a = 0;
writeln(n);
end.

(15.5k баллов)