1. Напишите программу, которая находит сумму двузначных нечётных чисел в...

0 голосов
100 просмотров

1. Напишите программу, которая находит сумму двузначных нечётных чисел в последовательности целых чисел. Программа получает на вход це¬лые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: сумму двузначных нечётных чисел в последовательности. Пример работы программы: Входные данные Выходные данные 11 26 15 30 9 0


Информатика (198 баллов) | 100 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
a, s: integer;
begin
s :=0;
repeat
readln(a);
if (a mod 2 <> 0) and (a < 100) and (a > 9) then
inc(s, a);
until a = 0;
writeln(s);
end.

(15.5k баллов)